Welcome !
         

 Problem with the @ symbol, help me please!!!!

Author Message
fecktor

  • Total Posts : 4
  • Scores: 0
  • Reward points : 0
  • Joined: 1/5/2017
  • Status: offline
Problem with the @ symbol, help me please!!!! Thursday, January 05, 2017 8:23 AM (permalink)
0
Hi, I'm working with vbs, but have a problem when i write the symbol @. This not appear in screen.
example: I write:  .SendKeys "user@2016"               and on screen only appear: 2016 
How can i to write the symbol @?
please help me, thanks
 
#1
    robnye

    • Total Posts : 4
    • Scores: 0
    • Reward points : 0
    • Joined: 12/14/2016
    • Status: offline
    Re:Problem with the @ symbol, help me please!!!! Friday, January 06, 2017 2:27 AM (permalink)
    0
    try changing the code to output the @ sign but calling the equivalent Char
     
    .SendKeys "user" & Chr$(64) & "2016"
     
    #2
      fecktor

      • Total Posts : 4
      • Scores: 0
      • Reward points : 0
      • Joined: 1/5/2017
      • Status: offline
      Re:Problem with the @ symbol, help me please!!!! Friday, January 06, 2017 3:42 AM (permalink)
      0
      I tried this way, but not working.
       
      I tested with ^%q, chr(64), [ALT] + 64 and nothing.

      thanks 
       
      #3
        robnye

        • Total Posts : 4
        • Scores: 0
        • Reward points : 0
        • Joined: 12/14/2016
        • Status: offline
        Re:Problem with the @ symbol, help me please!!!! Friday, January 06, 2017 4:09 AM (permalink)
        0
        mmm

        'To specify keys combined with any combination of the SHIFT, CTRL, and ALT keys, precede the key code with one or more of the following codes: '
        so @ requires shift key and '
        so @ = +'
        <message edited by robnye on Friday, January 06, 2017 4:10 AM>
         
        #4
          59cobalt

          • Total Posts : 2609
          • Scores: 253
          • Reward points : 0
          • Joined: 7/17/2011
          • Status: offline
          Re:Problem with the @ symbol, help me please!!!! Friday, January 06, 2017 4:58 AM (permalink)
          0
          SendKeys can send @ characters just fine. You can verify by sending your string to a Notepad window:
          Set sh = CreateObject("WScript.Shell")
          sh.Run "notepad.exe"
          WScript.Sleep 500
          sh.AppActivate "Notepad"
          sh.SendKeys "user@2016"
          If that doesn't work there's probably some software intercepting the keystrokes being sent.
          Where are you sending them anyway? And what does the rest of your code look like?
           
          #5
            fecktor

            • Total Posts : 4
            • Scores: 0
            • Reward points : 0
            • Joined: 1/5/2017
            • Status: offline
            Re:Problem with the @ symbol, help me please!!!! Friday, January 06, 2017 6:10 AM (permalink)
            0
            I want to sending password of putty's profile.
            Finally I solved the problem, I sended the password in the connection string with -pw user@2016.
            thanks for your time :)
             
            #6
              Online Bookmarks Sharing: Share/Bookmark

              Jump to:

              Current active users

              There are 0 members and 1 guests.

              Icon Legend and Permission

              • New Messages
              • No New Messages
              • Hot Topic w/ New Messages
              • Hot Topic w/o New Messages
              • Locked w/ New Messages
              • Locked w/o New Messages
              • Read Message
              • Post New Thread
              • Reply to message
              • Post New Poll
              • Submit Vote
              • Post reward post
              • Delete my own posts
              • Delete my own threads
              • Rate post

              2000-2017 ASPPlayground.NET Forum Version 3.9