Welcome !
         

 Problems with ASP-page and Firefox

Author Message
Jericho

  • Total Posts : 5
  • Scores: 0
  • Reward points : 0
  • Joined: 11/4/2013
  • Status: offline
Problems with ASP-page and Firefox Monday, November 04, 2013 9:04 PM (permalink)
0
Hi,
we have the following problem with a page which has vbscript-content and html-content.
We migrated from one server (IIS 6.0) to another (IIS 7.5) and since then all sites with vbscript which begin with <% and ends with %> are working no more in Firefox.
Is there a way to register this characters <% and %> for beginning and ending a code in IIS.
Sorry for my english...
 
Thank you for help!
 
Regards
Jericho
 
#1
    59cobalt

    • Total Posts : 2631
    • Scores: 253
    • Reward points : 0
    • Joined: 7/17/2011
    • Status: offline
    Re:Problems with ASP-page and Firefox Monday, November 04, 2013 10:07 PM (permalink)
    0
    Sounds to me like you didn't enable/configure ASP in your IIS 7.5, since code between <% %> is supposed to be processed on the server side. The client should never see this.
     
    #2
      Jericho

      • Total Posts : 5
      • Scores: 0
      • Reward points : 0
      • Joined: 11/4/2013
      • Status: offline
      Re:Problems with ASP-page and Firefox Monday, November 04, 2013 11:01 PM (permalink)
      0
      ...
      <message edited by Jericho on Monday, November 04, 2013 11:03 PM>
       
      #3
        Jericho

        • Total Posts : 5
        • Scores: 0
        • Reward points : 0
        • Joined: 11/4/2013
        • Status: offline
        Re:Problems with ASP-page and Firefox Monday, November 04, 2013 11:06 PM (permalink)
        0
        As I can see, ASP is enabled. It seems so because it works in IE.
         
        #4
          Jericho

          • Total Posts : 5
          • Scores: 0
          • Reward points : 0
          • Joined: 11/4/2013
          • Status: offline
          Re:Problems with ASP-page and Firefox Tuesday, November 05, 2013 12:04 AM (permalink)
          0
          The code of the index.asp looks as follows:
           
          ******** BEGIN CODE *************
           <!--#include file="inc/funktionen.asp" -->
           <%	'
           if session("Haendler") = "" AND session("SonderangeboteAngezeigt")="" then
           'set r = server.CreateObject("ADODB.RecordSet") 
           'r.open "SELECT * FROM Artikel WHERE EndkundenRabatt>0", conn, 3, 1
           'if r.recordcount>0 then					'	r.close		'	set r = nothing
           'session("SonderangeboteAngezeigt")="true"
           'response.Redirect("shop.asp?grp=Sonderangebote")
           'end if
           'r.close		'set r = nothing
           'end if%>
           <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
           <html lang=de-de xml:lang="de-de" xmlns="http://www.w3.org/1999/xhtml">
           <head>	<title>Quad Briel GmbH - Quad &amp; ATV - Zubehör: | Tel. 06455/75055 | Gossenhöfe 1 - 35110 Frankenau</title>
           <meta http-equiv=content-type content="text/html; charset=iso-8859-1" />
           <meta http-equiv="cache-control" content="no-cache">
           <meta name="robots" content="index, follow" />	<link href="style.css" type="text/css" rel="stylesheet" /></head>
          <body>
           <div id="main">
           <div id="kopf">			&nbsp;
           </div>
           

           
          ... and so on
           
          ******* END CODE *******
           
          #5
            59cobalt

            • Total Posts : 2631
            • Scores: 253
            • Reward points : 0
            • Joined: 7/17/2011
            • Status: offline
            Re:Problems with ASP-page and Firefox Tuesday, November 05, 2013 1:15 AM (permalink)
            0
            That shouldn't do anything at all, because all VBScript instructions are commented out.

            BTW, how exactly does it "not work" in Firefox? How does the behavior differ from IE? Do you get different page sourcecode in the two browsers?
             
            #6
              Jericho

              • Total Posts : 5
              • Scores: 0
              • Reward points : 0
              • Joined: 11/4/2013
              • Status: offline
              Re:Problems with ASP-page and Firefox Tuesday, November 05, 2013 1:54 AM (permalink)
              0
              HTML-Code is interpreted correctly and everthing which is between <% and %> is just put out as plain text.
              This happens in Firefox.
              In IE the code between <% and %> is obviously interpreted correctly.
              <message edited by Jericho on Tuesday, November 05, 2013 1:55 AM>
               
              #7
                59cobalt

                • Total Posts : 2631
                • Scores: 253
                • Reward points : 0
                • Joined: 7/17/2011
                • Status: offline
                Re:Problems with ASP-page and Firefox Tuesday, November 05, 2013 3:57 AM (permalink)
                0
                As I suspected: ASP either isn't installed or isn't configured correctly in your IIS 7.5. The <% %> markers and anything between them are supposed to be processed on the server. You shouldn't see that code on the client. Firefox doesn't support client-side VBScript. Or rather, no browser except IE supports client-side VBScript. Use JavaScript if you need client-side scripts.
                 
                #8
                  ClayDweller

                  • Total Posts : 3
                  • Scores: 0
                  • Reward points : 0
                  • Joined: 3/19/2014
                  • Status: offline
                  Re:Problems with ASP-page and Firefox Wednesday, March 19, 2014 6:15 PM (permalink)
                  0
                  ASP either isn't installed or isn't configured correctly in your IIS 7.5. The <% %> markers and anything between them are supposed to be processed on the server.
                   
                  #9
                    Online Bookmarks Sharing: Share/Bookmark

                    Jump to:

                    Current active users

                    There are 0 members and 1 guests.

                    Icon Legend and Permission

                    • New Messages
                    • No New Messages
                    • Hot Topic w/ New Messages
                    • Hot Topic w/o New Messages
                    • Locked w/ New Messages
                    • Locked w/o New Messages
                    • Read Message
                    • Post New Thread
                    • Reply to message
                    • Post New Poll
                    • Submit Vote
                    • Post reward post
                    • Delete my own posts
                    • Delete my own threads
                    • Rate post

                    2000-2017 ASPPlayground.NET Forum Version 3.9